summaryrefslogtreecommitdiffstats
path: root/toolkit/components/kvstore/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/components/kvstore/Cargo.toml')
-rw-r--r--toolkit/components/kvstore/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/toolkit/components/kvstore/Cargo.toml b/toolkit/components/kvstore/Cargo.toml
new file mode 100644
index 0000000000..2354a5d339
--- /dev/null
+++ b/toolkit/components/kvstore/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "kvstore"
+version = "0.1.0"
+authors = ["Myk Melez <myk@mykzilla.org>"]
+license = "MPL-2.0"
+
+[dependencies]
+atomic_refcell = "0.1"
+crossbeam-utils = "0.8"
+cstr = "0.2"
+lazy_static = "1"
+libc = "0.2"
+log = "0.4"
+moz_task = { path = "../../../xpcom/rust/moz_task" }
+nserror = { path = "../../../xpcom/rust/nserror" }
+nsstring = { path = "../../../xpcom/rust/nsstring" }
+rkv = { version = "0.18", default-features = false, features=["no-canonicalize-path"] }
+storage_variant = { path = "../../../storage/variant" }
+xpcom = { path = "../../../xpcom/rust/xpcom" }
+tempfile = "3"
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
+thiserror = "1"