summaryrefslogtreecommitdiffstats
path: root/toolkit/components/protobuf/README.txt
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/components/protobuf/README.txt')
-rw-r--r--toolkit/components/protobuf/README.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/toolkit/components/protobuf/README.txt b/toolkit/components/protobuf/README.txt
new file mode 100644
index 0000000000..14a65b897a
--- /dev/null
+++ b/toolkit/components/protobuf/README.txt
@@ -0,0 +1,28 @@
+Protocol Buffers (protobuf) source is available at:
+
+ https://github.com/google/protobuf
+
+This code is covered under the BSD license (see COPYING.txt). Documentation is
+available at https://developers.google.com/protocol-buffers/.
+
+The tree's current version of the protobuf library is 21.6.
+
+We do not include the protobuf tests or the protoc compiler.
+
+--------------------------------------------------------------------------------
+
+# Upgrading the Protobuf Library
+
+1. Get a new protobuf release from https://github.com/google/protobuf/releases
+
+2. Run `$ ./toolkit/components/protobuf/upgrade_protobuf.sh ~/path/to/release/checkout/of/protobuf`.
+
+3. Update the moz.build to export the new set of headers and add any new .cc
+ files to the unified sources and remove old ones. Note that we only
+ need:
+ - files contained in the `libprotobuf_lite_la_SOURCES` target
+ (https://github.com/protocolbuffers/protobuf/blob/main/src/Makefile.am)
+ - the header files they need
+ - gzip streams (for devtools)
+
+4. Re-generate all .pb.cc and .pb.h files using `$ ./toolkit/components/protobuf/regenerate_cpp_files.sh`.