summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-footbridge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-footbridge/Makefile')
-rw-r--r--arch/arm/mach-footbridge/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/arch/arm/mach-footbridge/Makefile b/arch/arm/mach-footbridge/Makefile
new file mode 100644
index 000000000..55d570739
--- /dev/null
+++ b/arch/arm/mach-footbridge/Makefile
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the linux kernel.
+#
+
+# Object file lists.
+
+obj-y := common.o isa-irq.o isa.o isa-rtc.o dma-isa.o
+
+pci-y += dc21285.o
+pci-$(CONFIG_ARCH_CATS) += cats-pci.o
+pci-$(CONFIG_ARCH_EBSA285) += ebsa285-pci.o
+pci-$(CONFIG_ARCH_NETWINDER) += netwinder-pci.o
+
+obj-$(CONFIG_ARCH_CATS) += cats-hw.o isa-timer.o
+obj-$(CONFIG_ARCH_EBSA285) += ebsa285.o dc21285-timer.o
+obj-$(CONFIG_ARCH_NETWINDER) += netwinder-hw.o isa-timer.o
+
+obj-$(CONFIG_PCI) +=$(pci-y)
+