summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-s3c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-s3c/Makefile')
-rw-r--r--arch/arm/mach-s3c/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/arch/arm/mach-s3c/Makefile b/arch/arm/mach-s3c/Makefile
new file mode 100644
index 000000000..7c7d3318f
--- /dev/null
+++ b/arch/arm/mach-s3c/Makefile
@@ -0,0 +1,35 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Copyright 2009 Simtec Electronics
+
+ifdef CONFIG_ARCH_S3C24XX
+include $(src)/Makefile.s3c24xx
+endif
+
+ifdef CONFIG_ARCH_S3C64XX
+include $(src)/Makefile.s3c64xx
+endif
+
+# Objects we always build independent of SoC choice
+
+obj-y += init.o cpu.o
+
+# ADC
+
+obj-$(CONFIG_S3C_ADC) += adc.o
+
+# devices
+
+obj-$(CONFIG_SAMSUNG_ATAGS) += platformdata.o
+
+obj-$(CONFIG_SAMSUNG_ATAGS) += devs.o
+obj-$(CONFIG_SAMSUNG_ATAGS) += dev-uart.o
+
+obj-$(CONFIG_GPIO_SAMSUNG) += gpio-samsung.o
+
+# PM support
+
+obj-$(CONFIG_SAMSUNG_PM) += pm.o pm-common.o
+obj-$(CONFIG_SAMSUNG_PM_GPIO) += pm-gpio.o
+
+obj-$(CONFIG_SAMSUNG_WAKEMASK) += wakeup-mask.o