summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-socfpga/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-socfpga/Makefile')
-rw-r--r--arch/arm/mach-socfpga/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/arch/arm/mach-socfpga/Makefile b/arch/arm/mach-socfpga/Makefile
new file mode 100644
index 000000000..9ec31fad7
--- /dev/null
+++ b/arch/arm/mach-socfpga/Makefile
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the linux kernel.
+#
+
+obj-y := socfpga.o
+obj-$(CONFIG_SMP) += headsmp.o platsmp.o
+obj-$(CONFIG_SOCFPGA_SUSPEND) += pm.o self-refresh.o
+obj-$(CONFIG_EDAC_ALTERA_L2C) += l2_cache.o
+obj-$(CONFIG_EDAC_ALTERA_OCRAM) += ocram.o