summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-tegra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-tegra/Makefile')
-rw-r--r--arch/arm/mach-tegra/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/arch/arm/mach-tegra/Makefile b/arch/arm/mach-tegra/Makefile
new file mode 100644
index 000000000..07572b537
--- /dev/null
+++ b/arch/arm/mach-tegra/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0
+asflags-y += -march=armv7-a
+
+obj-y += io.o
+obj-y += irq.o
+obj-y += pm.o
+obj-y += reset.o
+obj-y += reset-handler.o
+obj-y += sleep.o
+obj-y += tegra.o
+obj-y += sleep-tegra20.o
+obj-y += sleep-tegra30.o
+obj-$(CONFIG_ARCH_TEGRA_2x_SOC) += pm-tegra20.o
+obj-$(CONFIG_ARCH_TEGRA_3x_SOC) += pm-tegra30.o
+obj-$(CONFIG_SMP) += platsmp.o
+obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
+
+obj-$(CONFIG_ARCH_TEGRA_114_SOC) += pm-tegra30.o
+obj-$(CONFIG_ARCH_TEGRA_124_SOC) += pm-tegra30.o
+
+obj-$(CONFIG_ARCH_TEGRA_2x_SOC) += board-paz00.o