summaryrefslogtreecommitdiffstats
path: root/arch/arm/plat-orion/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/plat-orion/Makefile')
-rw-r--r--arch/arm/plat-orion/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/arch/arm/plat-orion/Makefile b/arch/arm/plat-orion/Makefile
new file mode 100644
index 000000000..830b0be03
--- /dev/null
+++ b/arch/arm/plat-orion/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the linux kernel.
+#
+ccflags-y := -I$(srctree)/$(src)/include
+
+orion-gpio-$(CONFIG_GPIOLIB) += gpio.o
+obj-$(CONFIG_PLAT_ORION_LEGACY) += irq.o pcie.o time.o common.o mpp.o
+obj-$(CONFIG_PLAT_ORION_LEGACY) += $(orion-gpio-y)