summaryrefslogtreecommitdiffstats
path: root/drivers/net/bonding/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/bonding/Makefile')
-rw-r--r--drivers/net/bonding/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/net/bonding/Makefile b/drivers/net/bonding/Makefile
new file mode 100644
index 000000000..30e8ae3da
--- /dev/null
+++ b/drivers/net/bonding/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the Ethernet Bonding driver
+#
+
+obj-$(CONFIG_BONDING) += bonding.o
+
+bonding-objs := bond_main.o bond_3ad.o bond_alb.o bond_sysfs.o bond_sysfs_slave.o bond_debugfs.o bond_netlink.o bond_options.o
+
+proc-$(CONFIG_PROC_FS) += bond_procfs.o
+bonding-objs += $(proc-y)
+