summaryrefslogtreecommitdiffstats
path: root/fs/erofs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/erofs/Makefile')
-rw-r--r--fs/erofs/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/fs/erofs/Makefile b/fs/erofs/Makefile
new file mode 100644
index 000000000..99bbc597a
--- /dev/null
+++ b/fs/erofs/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+obj-$(CONFIG_EROFS_FS) += erofs.o
+erofs-objs := super.o inode.o data.o namei.o dir.o utils.o pcpubuf.o sysfs.o
+erofs-$(CONFIG_EROFS_FS_XATTR) += xattr.o
+erofs-$(CONFIG_EROFS_FS_ZIP) += decompressor.o zmap.o zdata.o
+erofs-$(CONFIG_EROFS_FS_ZIP_LZMA) += decompressor_lzma.o
+erofs-$(CONFIG_EROFS_FS_ONDEMAND) += fscache.o