summaryrefslogtreecommitdiffstats
path: root/fs/cachefiles/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/cachefiles/Makefile')
-rw-r--r--fs/cachefiles/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/fs/cachefiles/Makefile b/fs/cachefiles/Makefile
new file mode 100644
index 000000000..c37a7a9af
--- /dev/null
+++ b/fs/cachefiles/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for caching in a mounted filesystem
+#
+
+cachefiles-y := \
+ cache.o \
+ daemon.o \
+ interface.o \
+ io.o \
+ key.o \
+ main.o \
+ namei.o \
+ security.o \
+ volume.o \
+ xattr.o
+
+cachefiles-$(CONFIG_CACHEFILES_ERROR_INJECTION) += error_inject.o
+cachefiles-$(CONFIG_CACHEFILES_ONDEMAND) += ondemand.o
+
+obj-$(CONFIG_CACHEFILES) := cachefiles.o