summaryrefslogtreecommitdiffstats
path: root/fs/fscache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/fscache/Makefile')
-rw-r--r--fs/fscache/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/fs/fscache/Makefile b/fs/fscache/Makefile
new file mode 100644
index 000000000..afb090ea1
--- /dev/null
+++ b/fs/fscache/Makefile
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for general filesystem caching code
+#
+
+fscache-y := \
+ cache.o \
+ cookie.o \
+ io.o \
+ main.o \
+ volume.o
+
+fscache-$(CONFIG_PROC_FS) += proc.o
+fscache-$(CONFIG_FSCACHE_STATS) += stats.o
+
+obj-$(CONFIG_FSCACHE) := fscache.o