summaryrefslogtreecommitdiffstats
path: root/fs/romfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/romfs/Makefile')
-rw-r--r--fs/romfs/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/fs/romfs/Makefile b/fs/romfs/Makefile
new file mode 100644
index 000000000..844928f15
--- /dev/null
+++ b/fs/romfs/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the linux RomFS filesystem routines.
+#
+
+obj-$(CONFIG_ROMFS_FS) += romfs.o
+
+romfs-y := storage.o super.o
+
+ifneq ($(CONFIG_MMU),y)
+romfs-$(CONFIG_ROMFS_ON_MTD) += mmap-nommu.o
+endif
+