summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xdebian/tests/boot-and-services26
-rwxr-xr-xdebian/tests/logind6
3 files changed, 19 insertions, 26 deletions
diff --git a/debian/changelog b/debian/changelog
index 52ebc91..b9d8665 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+systemd (252.26-1~deb12u1) bookworm; urgency=medium
+
+ * New upstream version 252.26
+ * autopkgtest: reboot before logind test. If the testbed hasn't rebooted
+ the test session will be running in a logind session created by the
+ existing logind instead of the one under test, so reboot before
+ running.
+ * d/t/boot-and-services: drop tmp check. LXC now sets up a tmpfs on /tmp
+ as per upstream recommendation, so we cannot detect it via fstab
+ anymore.
+
+ -- Luca Boccassi <bluca@debian.org> Tue, 28 May 2024 13:50:58 +0100
+
systemd (252.25-1~deb12u1) bookworm; urgency=medium
* New upstream version 252.25
diff --git a/debian/tests/boot-and-services b/debian/tests/boot-and-services
index 1208922..e507aa6 100755
--- a/debian/tests/boot-and-services
+++ b/debian/tests/boot-and-services
@@ -124,32 +124,6 @@ class ServicesTest(unittest.TestCase):
self.assertIn(b'\nP: /devices/', out)
self.active_unit('systemd-udevd')
- def test_tmp_mount(self):
- # check if we want to mount /tmp in fstab
- want_tmp_mount = False
- try:
- with open('/etc/fstab') as f:
- for l in f:
- try:
- if not l.startswith('#') and l.split()[1] in ('/tmp', '/tmp/'):
- want_tmp_mount = True
- break
- except IndexError:
- pass
- except FileNotFoundError:
- pass
-
- # ensure that we actually do/don't have a /tmp mount
- (status, status_out) = subprocess.getstatusoutput('systemctl status tmp.mount')
- findmnt = subprocess.call(['findmnt', '-n', '/tmp'], stdout=subprocess.PIPE)
- if want_tmp_mount:
- self.assertEqual(status, 0, status_out)
- self.assertEqual(findmnt, 0)
- else:
- # 4 is correct (since upstream commit ca473d57), accept 3 for systemd <= 230
- self.assertIn(status, [3, 4], status_out)
- self.assertNotEqual(findmnt, 0)
-
@unittest.skipIf('TEST_UPSTREAM' in os.environ,
'Debian specific configuration, N/A for upstream')
def test_tmp_cleanup(self):
diff --git a/debian/tests/logind b/debian/tests/logind
index eea4005..a53910c 100755
--- a/debian/tests/logind
+++ b/debian/tests/logind
@@ -202,6 +202,12 @@ EOF
# main
#
+# Make sure we are running with the logind package under test instead of the one
+# from the base distro
+if [ -z "$AUTOPKGTEST_REBOOT_MARK" ]; then
+ /tmp/autopkgtest-reboot 1
+fi
+
test_started
test_properties
test_in_logind_session