summaryrefslogtreecommitdiffstats
path: root/build/program.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build/program.mk')
-rw-r--r--build/program.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/build/program.mk b/build/program.mk
new file mode 100644
index 0000000..565b51f
--- /dev/null
+++ b/build/program.mk
@@ -0,0 +1,23 @@
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed with
+# this work for additional information regarding copyright ownership.
+# The ASF licenses this file to You under the Apache License, Version 2.0
+# (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+#
+# The build environment was provided by Sascha Schumann.
+
+PROGRAM_OBJECTS = $(PROGRAM_SOURCES:.c=.lo)
+
+$(PROGRAM_NAME): $(PROGRAM_DEPENDENCIES) $(PROGRAM_OBJECTS)
+ $(PROGRAM_PRELINK)
+ $(LINK) $(PROGRAM_LDFLAGS) $(PROGRAM_OBJECTS) $(PROGRAM_LDADD)