summaryrefslogtreecommitdiffstats
path: root/os/config.m4
diff options
context:
space:
mode:
Diffstat (limited to 'os/config.m4')
-rw-r--r--os/config.m426
1 files changed, 26 insertions, 0 deletions
diff --git a/os/config.m4 b/os/config.m4
new file mode 100644
index 0000000..3188091
--- /dev/null
+++ b/os/config.m4
@@ -0,0 +1,26 @@
+AC_MSG_CHECKING(for target platform)
+
+case $host in
+*pc-os2-emx*)
+ OS="os2"
+ OS_DIR=$OS
+ ;;
+bs2000*)
+ OS="unix"
+ OS_DIR=$OS
+ ;;
+*cygwin*)
+ OS="cygwin"
+ OS_DIR="unix"
+ ;;
+*mingw32*)
+ OS="win32"
+ OS_DIR=$OS
+ ;;
+*)
+ OS="unix"
+ OS_DIR=$OS;;
+esac
+
+AC_MSG_RESULT($OS)
+APACHE_FAST_OUTPUT(os/${OS_DIR}/Makefile)