summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:59:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:59:48 +0000
commit3b9b6d0b8e7f798023c9d109c490449d528fde80 (patch)
tree2e1c188dd7b8d7475cd163de9ae02c428343669b /Makefile.am
parentInitial commit. (diff)
downloadbind9-upstream.tar.xz
bind9-upstream.zip
Adding upstream version 1:9.18.19.upstream/1%9.18.19upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..2f09561
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+include $(top_srcdir)/Makefile.top
+
+SUBDIRS = . lib doc bin fuzz
+
+if HAVE_CMOCKA
+SUBDIRS += tests
+endif HAVE_CMOCKA
+
+BUILT_SOURCES = bind.keys.h
+CLEANFILES = bind.keys.h
+
+bind.keys.h: bind.keys Makefile
+ ${PERL} ${top_srcdir}/util/bindkeys.pl ${top_srcdir}/bind.keys > $@
+
+dist_sysconf_DATA = bind.keys
+
+.PHONY: doc
+
+EXTRA_DIST = \
+ util/bindkeys.pl \
+ contrib \
+ CHANGES \
+ COPYRIGHT \
+ LICENSE \
+ *.md
+
+dist-hook:
+ find $(distdir) -type f -name .gitignore -delete
+ git rev-parse --short HEAD | cut -b1-7 > $(distdir)/srcid