summaryrefslogtreecommitdiffstats
path: root/Makefile.tests
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:59:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:59:48 +0000
commit3b9b6d0b8e7f798023c9d109c490449d528fde80 (patch)
tree2e1c188dd7b8d7475cd163de9ae02c428343669b /Makefile.tests
parentInitial commit. (diff)
downloadbind9-3b9b6d0b8e7f798023c9d109c490449d528fde80.tar.xz
bind9-3b9b6d0b8e7f798023c9d109c490449d528fde80.zip
Adding upstream version 1:9.18.19.upstream/1%9.18.19upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.tests')
-rw-r--r--Makefile.tests23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.tests b/Makefile.tests
new file mode 100644
index 0000000..e1b7e0e
--- /dev/null
+++ b/Makefile.tests
@@ -0,0 +1,23 @@
+# Hey Emacs, this is -*- makefile-automake -*- file!
+# vim: filetype=automake
+
+unit-local: check
+
+if HAVE_CMOCKA
+TESTS = $(check_PROGRAMS)
+endif HAVE_CMOCKA
+
+LOG_COMPILER = $(top_builddir)/tests/unit-test-driver.sh
+
+AM_CFLAGS += \
+ -I$(top_srcdir)/tests/include \
+ $(TEST_CFLAGS)
+
+AM_CPPFLAGS += \
+ $(CMOCKA_CFLAGS) \
+ -DNAMED_PLUGINDIR=\"$(pkglibdir)\" \
+ -DTESTS_DIR=\"$(abs_srcdir)\"
+
+LDADD += \
+ $(top_builddir)/tests/libtest/libtest.la \
+ $(CMOCKA_LIBS)