summaryrefslogtreecommitdiffstats
path: root/fuzz/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:59:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:59:48 +0000
commit3b9b6d0b8e7f798023c9d109c490449d528fde80 (patch)
tree2e1c188dd7b8d7475cd163de9ae02c428343669b /fuzz/Makefile.am
parentInitial commit. (diff)
downloadbind9-3b9b6d0b8e7f798023c9d109c490449d528fde80.tar.xz
bind9-3b9b6d0b8e7f798023c9d109c490449d528fde80.zip
Adding upstream version 1:9.18.19.upstream/1%9.18.19upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fuzz/Makefile.am')
-rw-r--r--fuzz/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/fuzz/Makefile.am b/fuzz/Makefile.am
new file mode 100644
index 0000000..eb4a2f4
--- /dev/null
+++ b/fuzz/Makefile.am
@@ -0,0 +1,51 @@
+include $(top_srcdir)/Makefile.top
+
+AM_CFLAGS += \
+ $(TEST_CFLAGS)
+
+AM_CPPFLAGS += \
+ $(LIBISC_CFLAGS) \
+ $(LIBDNS_CFLAGS) \
+ -DFUZZDIR=\"$(abs_srcdir)\"
+
+AM_LDFLAGS += \
+ $(FUZZ_LDFLAGS)
+
+LDADD += \
+ libfuzzmain.la \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS)
+
+check_LTLIBRARIES = libfuzzmain.la
+libfuzzmain_la_SOURCES = \
+ fuzz.h \
+ main.c
+
+check_PROGRAMS = \
+ dns_master_load \
+ dns_message_checksig \
+ dns_message_parse \
+ dns_name_fromtext_target \
+ dns_rdata_fromtext \
+ dns_rdata_fromwire_text \
+ isc_lex_getmastertoken \
+ isc_lex_gettoken
+
+EXTRA_DIST = \
+ dns_master_load.in \
+ dns_message_checksig.in \
+ dns_message_parse.in \
+ dns_name_fromtext_target.in \
+ dns_rdata_fromtext.in \
+ dns_rdata_fromwire_text.in \
+ isc_lex_getmastertoken.in \
+ isc_lex_gettoken.in
+
+TESTS = $(check_PROGRAMS)
+
+if HAVE_FUZZ_LOG_COMPILER
+LOG_COMPILER = $(srcdir)/$(FUZZ_LOG_COMPILER)
+AM_LOG_FLAGS = $(srcdir)
+endif HAVE_FUZZ_LOG_COMPILER
+
+unit-local: check