summaryrefslogtreecommitdiffstats
path: root/bin/confgen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/confgen/Makefile.am')
-rw-r--r--bin/confgen/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/bin/confgen/Makefile.am b/bin/confgen/Makefile.am
new file mode 100644
index 0000000..c1dca43
--- /dev/null
+++ b/bin/confgen/Makefile.am
@@ -0,0 +1,30 @@
+include $(top_srcdir)/Makefile.top
+
+AM_CPPFLAGS += \
+ $(LIBISC_CFLAGS) \
+ $(LIBDNS_CFLAGS) \
+ -DRNDC_KEYFILE=\"${sysconfdir}/rndc.key\"
+
+LDADD += \
+ libconfgen.la \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS)
+
+noinst_LTLIBRARIES = libconfgen.la
+
+libconfgen_la_SOURCES = \
+ include/confgen/os.h \
+ keygen.c \
+ keygen.h \
+ os.c \
+ util.c \
+ util.h
+
+sbin_PROGRAMS = tsig-keygen rndc-confgen
+
+install-exec-hook:
+ ln -f $(DESTDIR)$(sbindir)/tsig-keygen \
+ $(DESTDIR)$(sbindir)/ddns-confgen
+
+uninstall-hook:
+ -rm -f $(DESTDIR)$(sbindir)/ddns-confgen