summaryrefslogtreecommitdiffstats
path: root/bin/nsupdate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/nsupdate/Makefile.am')
-rw-r--r--bin/nsupdate/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/bin/nsupdate/Makefile.am b/bin/nsupdate/Makefile.am
new file mode 100644
index 0000000..18c8645
--- /dev/null
+++ b/bin/nsupdate/Makefile.am
@@ -0,0 +1,34 @@
+include $(top_srcdir)/Makefile.top
+
+AM_CPPFLAGS += \
+ $(LIBISC_CFLAGS) \
+ $(LIBDNS_CFLAGS) \
+ $(LIBISCCFG_CFLAGS) \
+ $(LIBIRS_CFLAGS) \
+ $(LIBBIND9_CFLAGS) \
+ $(GSSAPI_CFLAGS) \
+ $(KRB5_CFLAGS) \
+ $(READLINE_CFLAGS)
+
+AM_CPPFLAGS += \
+ -DSESSION_KEYFILE=\"${localstatedir}/run/named/session.key\"
+
+LDADD += \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS) \
+ $(LIBISCCFG_LIBS) \
+ $(LIBIRS_LIBS) \
+ $(LIBBIND9_LIBS) \
+ $(GSSAPI_LIBS) \
+ $(KRB5_LIBS)
+
+if HAVE_READLINE
+LDADD += \
+ $(READLINE_LIBS)
+endif
+
+bin_PROGRAMS = nsupdate
+
+nsupdate_SOURCES = \
+ nsupdate.c \
+ ../dig/readline.h