summaryrefslogtreecommitdiffstats
path: root/bin/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/tests/Makefile.am')
-rw-r--r--bin/tests/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/bin/tests/Makefile.am b/bin/tests/Makefile.am
new file mode 100644
index 0000000..56e81b1
--- /dev/null
+++ b/bin/tests/Makefile.am
@@ -0,0 +1,38 @@
+include $(top_srcdir)/Makefile.top
+
+EXTRA_DIST = convert-trs-to-junit.py
+
+SUBDIRS = system
+
+noinst_PROGRAMS = \
+ test_client \
+ test_server \
+ wire_test
+
+AM_CFLAGS += \
+ $(TEST_CFLAGS)
+
+test_client_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBISC_CFLAGS)
+
+test_client_LDADD = \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS)
+
+test_server_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBISC_CFLAGS)
+
+test_server_LDADD = \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS)
+
+wire_test_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBISC_CFLAGS) \
+ $(LIBDNS_CFLAGS)
+
+wire_test_LDADD = \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS)