summaryrefslogtreecommitdiffstats
path: root/tests/libtest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/libtest/Makefile.am')
-rw-r--r--tests/libtest/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
new file mode 100644
index 0000000..6bd4b80
--- /dev/null
+++ b/tests/libtest/Makefile.am
@@ -0,0 +1,25 @@
+include $(top_srcdir)/Makefile.top
+
+AM_CPPFLAGS += \
+ $(LIBISC_CFLAGS) \
+ $(LIBDNS_CFLAGS) \
+ $(LIBNS_CFLAGS) \
+ $(LIBUV_CFLAGS) \
+ -I$(top_srcdir)/lib/isc
+
+LDADD += \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS) \
+ $(LIBNS_LIBS)
+
+check_LTLIBRARIES = libtest.la
+
+libtest_la_SOURCES = \
+ ../include/tests/dns.h \
+ ../include/tests/isc.h \
+ ../include/tests/ns.h \
+ dns.c \
+ isc.c \
+ ns.c
+
+include $(top_srcdir)/Makefile.tests