summaryrefslogtreecommitdiffstats
path: root/tests/ns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ns/Makefile.am')
-rw-r--r--tests/ns/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/ns/Makefile.am b/tests/ns/Makefile.am
new file mode 100644
index 0000000..33f91d8
--- /dev/null
+++ b/tests/ns/Makefile.am
@@ -0,0 +1,25 @@
+include $(top_srcdir)/Makefile.top
+
+AM_CPPFLAGS += \
+ $(LIBISC_CFLAGS) \
+ $(LIBDNS_CFLAGS) \
+ $(LIBNS_CFLAGS) \
+ $(LIBUV_CFLAGS) \
+ -I$(top_srcdir)/lib/isc \
+ -I$(top_srcdir)/lib/dns
+
+LDADD += \
+ $(LIBISC_LIBS) \
+ $(LIBDNS_LIBS) \
+ $(LIBNS_LIBS) \
+ $(LIBUV_LIBS)
+
+check_PROGRAMS = \
+ listenlist_test \
+ notify_test \
+ plugin_test \
+ query_test
+
+EXTRA_DIST = testdata
+
+include $(top_srcdir)/Makefile.tests