summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/conversion/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/boost/libs/conversion/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/conversion/CMakeLists.txt')
-rw-r--r--src/boost/libs/conversion/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/boost/libs/conversion/CMakeLists.txt b/src/boost/libs/conversion/CMakeLists.txt
new file mode 100644
index 000000000..b333aab03
--- /dev/null
+++ b/src/boost/libs/conversion/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright 2019 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: CMake support for Boost.Conversion is currently experimental at best
+# and the interface is likely to change in the future
+
+cmake_minimum_required( VERSION 3.5 )
+project( BoostConversion LANGUAGES CXX )
+
+add_library( boost_conversion INTERFACE )
+add_library( Boost::conversion ALIAS boost_conversion )
+
+target_include_directories( boost_conversion INTERFACE include )
+
+target_link_libraries( boost_conversion
+ INTERFACE
+ Boost::assert
+ Boost::config
+ Boost::smart_ptr
+ Boost::throw_exception
+ Boost::type_traits
+ Boost::typeof
+)