summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/utility/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/boost/libs/utility/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/utility/CMakeLists.txt')
-rw-r--r--src/boost/libs/utility/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/boost/libs/utility/CMakeLists.txt b/src/boost/libs/utility/CMakeLists.txt
new file mode 100644
index 000000000..25177b0d6
--- /dev/null
+++ b/src/boost/libs/utility/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright 2018 Peter Dimov
+# Copyright 2018 Andrey Semashev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+
+# Partial (add_subdirectory only) and experimental CMake support
+# Subject to change; please do not rely on the contents of this file yet.
+
+cmake_minimum_required(VERSION 3.5)
+
+project(BoostUtility LANGUAGES CXX)
+
+add_library(boost_utility INTERFACE)
+add_library(Boost::utility ALIAS boost_utility)
+
+target_include_directories(boost_utility INTERFACE include)
+
+target_link_libraries(boost_utility
+ INTERFACE
+ Boost::config
+ Boost::container_hash
+ Boost::core
+ Boost::preprocessor
+ Boost::static_assert
+ Boost::throw_exception
+ Boost::type_traits
+)