summaryrefslogtreecommitdiffstats
path: root/src/civetweb/contrib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/civetweb/contrib
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/contrib')
-rw-r--r--src/civetweb/contrib/buildroot/Config.in26
-rw-r--r--src/civetweb/contrib/buildroot/civetweb.mk55
2 files changed, 81 insertions, 0 deletions
diff --git a/src/civetweb/contrib/buildroot/Config.in b/src/civetweb/contrib/buildroot/Config.in
new file mode 100644
index 000000000..2334fdfe8
--- /dev/null
+++ b/src/civetweb/contrib/buildroot/Config.in
@@ -0,0 +1,26 @@
+config BR2_PACKAGE_CIVETWEB
+ bool "civetweb"
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ Full featured embedded web server with Lua support.
+
+ https://sourceforge.net/projects/civetweb
+
+if BR2_PACKAGE_CIVETWEB
+
+config BR2_CIVETWEB_WITH_LUA
+ bool "enable Lua support"
+ # required by the bundled Sqlite3 and Lua code
+ depends on BR2_LARGEFILE
+ help
+ Enable Lua support in Civetweb. Note that this will use a
+ version of Lua and Sqlite bundled within the Civetweb
+ sources, and not the packages from Buildroot.
+
+comment "Lua support requires largefile support in toolchain"
+ depends on !BR2_LARGEFILE
+
+endif
+
+comment "civetweb requires a toolchain with PTHREAD support"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/src/civetweb/contrib/buildroot/civetweb.mk b/src/civetweb/contrib/buildroot/civetweb.mk
new file mode 100644
index 000000000..8b9b7de0b
--- /dev/null
+++ b/src/civetweb/contrib/buildroot/civetweb.mk
@@ -0,0 +1,55 @@
+################################################################################
+#
+# civetweb
+#
+################################################################################
+
+CIVETWEB_VERSION = 1.10
+CIVETWEB_SITE = http://github.com/civetweb/civetweb/tarball/v$(CIVETWEB_VERSION)
+CIVETWEB_LICENSE = MIT
+CIVETWEB_LICENSE_FILES = LICENSE.md
+
+CIVETWEB_CONF_OPT = TARGET_OS=LINUX
+CIVETWEB_COPT = $(TARGET_CFLAGS) -DHAVE_POSIX_FALLOCATE=0
+CIVETWEB_LDFLAGS = $(TARGET_LDFLAGS)
+CIVETWEB_SYSCONFDIR = /etc
+CIVETWEB_HTMLDIR = /var/www
+
+ifneq ($(BR2_LARGEFILE),y)
+ CIVETWEB_COPT += -DSQLITE_DISABLE_LFS
+endif
+
+ifeq ($(BR2_INET_IPV6),y)
+ CIVETWEB_CONF_OPT += WITH_IPV6=1
+endif
+
+ifeq ($(BR2_CIVETWEB_WITH_LUA),y)
+ CIVETWEB_CONF_OPT += WITH_LUA=1
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ CIVETWEB_COPT += -DNO_SSL_DL -lcrypt -lssl
+ CIVETWEB_DEPENDENCIES += openssl
+else
+ CIVETWEB_COPT += -DNO_SSL
+endif
+
+define CIVETWEB_BUILD_CMDS
+ $(MAKE) CC="$(TARGET_CC)" -C $(@D) build \
+ $(CIVETWEB_CONF_OPT) \
+ COPT="$(CIVETWEB_COPT)"
+endef
+
+define CIVETWEB_INSTALL_TARGET_CMDS
+ $(MAKE) CC="$(TARGET_CC)" -C $(@D) install \
+ DOCUMENT_ROOT="$(CIVETWEB_HTMLDIR)" \
+ CONFIG_FILE2="$(CIVETWEB_SYSCONFDIR)/civetweb.conf" \
+ HTMLDIR="$(TARGET_DIR)$(CIVETWEB_HTMLDIR)" \
+ SYSCONFDIR="$(TARGET_DIR)$(CIVETWEB_SYSCONFDIR)" \
+ PREFIX="$(TARGET_DIR)/usr" \
+ $(CIVETWEB_CONF_OPT) \
+ COPT='$(CIVETWEB_COPT)'
+endef
+
+$(eval $(generic-package))
+