summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pybind/mgr/dashboard/frontend/tsconfig.spec.json')
-rw-r--r--src/pybind/mgr/dashboard/frontend/tsconfig.spec.json21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json b/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
new file mode 100644
index 000000000..e1889d6c6
--- /dev/null
+++ b/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
@@ -0,0 +1,21 @@
+{
+ "extends": "./tsconfig.json",
+ "compilerOptions": {
+ "outDir": "./out-tsc/spec",
+ "module": "commonjs",
+ "target": "es2015",
+ "types": [
+ "jest",
+ "node"
+ ],
+ "noEmit": true
+ },
+ "files": [
+ "src/polyfills.ts"
+ ],
+ "include": [
+ "src/**/*.spec.ts",
+ "src/**/*.d.ts",
+ "src/testing/*.ts"
+ ]
+}