summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/bus/vdev/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/seastar/dpdk/drivers/bus/vdev/Makefile
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/seastar/dpdk/drivers/bus/vdev/Makefile')
-rw-r--r--src/seastar/dpdk/drivers/bus/vdev/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/bus/vdev/Makefile b/src/seastar/dpdk/drivers/bus/vdev/Makefile
new file mode 100644
index 000000000..803b8ea7b
--- /dev/null
+++ b/src/seastar/dpdk/drivers/bus/vdev/Makefile
@@ -0,0 +1,31 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+#
+# library name
+#
+LIB = librte_bus_vdev.a
+
+CFLAGS += -O3
+CFLAGS += $(WERROR_FLAGS)
+CFLAGS += -DALLOW_EXPERIMENTAL_API
+
+# versioning export map
+EXPORT_MAP := rte_bus_vdev_version.map
+
+# library version
+LIBABIVER := 2
+
+SRCS-y += vdev.c
+SRCS-y += vdev_params.c
+
+LDLIBS += -lrte_eal -lrte_kvargs
+
+#
+# Export include files
+#
+SYMLINK-y-include += rte_bus_vdev.h
+
+include $(RTE_SDK)/mk/rte.lib.mk