summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/net/af_xdp/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/seastar/dpdk/drivers/net/af_xdp/meson.build
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/seastar/dpdk/drivers/net/af_xdp/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/net/af_xdp/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/net/af_xdp/meson.build b/src/seastar/dpdk/drivers/net/af_xdp/meson.build
new file mode 100644
index 000000000..7904840f0
--- /dev/null
+++ b/src/seastar/dpdk/drivers/net/af_xdp/meson.build
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2019 Intel Corporation
+
+sources = files('rte_eth_af_xdp.c')
+
+bpf_dep = dependency('libbpf', required: false)
+if not bpf_dep.found()
+ bpf_dep = cc.find_library('bpf', required: false)
+endif
+
+if bpf_dep.found() and cc.has_header('bpf/xsk.h') and cc.has_header('linux/if_xdp.h')
+ ext_deps += bpf_dep
+ pkgconfig_extra_libs += '-lbpf'
+else
+ build = false
+endif