summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/lib/librte_bpf/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/seastar/dpdk/lib/librte_bpf/meson.build
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/seastar/dpdk/lib/librte_bpf/meson.build')
-rw-r--r--src/seastar/dpdk/lib/librte_bpf/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/seastar/dpdk/lib/librte_bpf/meson.build b/src/seastar/dpdk/lib/librte_bpf/meson.build
new file mode 100644
index 000000000..8a79878ff
--- /dev/null
+++ b/src/seastar/dpdk/lib/librte_bpf/meson.build
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+allow_experimental_apis = true
+sources = files('bpf.c',
+ 'bpf_exec.c',
+ 'bpf_load.c',
+ 'bpf_pkt.c',
+ 'bpf_validate.c')
+
+if arch_subdir == 'x86' and dpdk_conf.get('RTE_ARCH_64')
+ sources += files('bpf_jit_x86.c')
+endif
+
+install_headers = files('bpf_def.h',
+ 'rte_bpf.h',
+ 'rte_bpf_ethdev.h')
+
+deps += ['mbuf', 'net', 'ethdev']
+
+dep = dependency('libelf', required: false)
+if dep.found()
+ sources += files('bpf_load_elf.c')
+ ext_deps += dep
+endif