summaryrefslogtreecommitdiffstats
path: root/debian/patches/add-option-to-disable-ceph-dencoder.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/add-option-to-disable-ceph-dencoder.patch')
-rw-r--r--debian/patches/add-option-to-disable-ceph-dencoder.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/patches/add-option-to-disable-ceph-dencoder.patch b/debian/patches/add-option-to-disable-ceph-dencoder.patch
new file mode 100644
index 000000000..ef813e505
--- /dev/null
+++ b/debian/patches/add-option-to-disable-ceph-dencoder.patch
@@ -0,0 +1,12 @@
+Index: ceph/src/tools/CMakeLists.txt
+===================================================================
+--- ceph.orig/src/tools/CMakeLists.txt
++++ ceph/src/tools/CMakeLists.txt
+@@ -151,5 +151,7 @@ if(WITH_SEASTAR)
+ endif()
+
+ add_subdirectory(immutable_object_cache)
++if(NOT DISABLE_DENCODER)
+ add_subdirectory(ceph-dencoder)
++endif(DISABLE_DENCODER)
+ add_subdirectory(erasure-code)