summaryrefslogtreecommitdiffstats
path: root/debian/patches/disable-crypto.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/disable-crypto.patch')
-rw-r--r--debian/patches/disable-crypto.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/disable-crypto.patch b/debian/patches/disable-crypto.patch
new file mode 100644
index 000000000..b25aaac1b
--- /dev/null
+++ b/debian/patches/disable-crypto.patch
@@ -0,0 +1,16 @@
+Index: ceph/src/os/CMakeLists.txt
+===================================================================
+--- ceph.orig/src/os/CMakeLists.txt
++++ ceph/src/os/CMakeLists.txt
+@@ -98,8 +98,9 @@ endif()
+ target_link_libraries(os kv)
+
+ add_dependencies(os compressor_plugins)
+-add_dependencies(os crypto_plugins)
+-
++if(HAVE_INTEL AND HAVE_BETTER_YASM_ELF64 AND (NOT APPLE))
++ add_dependencies(os crypto_plugins)
++endif()
+
+ if(WITH_BLUESTORE)
+ add_executable(ceph-bluestore-tool