summaryrefslogtreecommitdiffstats
path: root/etc/sysctl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'etc/sysctl/CMakeLists.txt')
-rw-r--r--etc/sysctl/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/etc/sysctl/CMakeLists.txt b/etc/sysctl/CMakeLists.txt
new file mode 100644
index 000000000..682541b05
--- /dev/null
+++ b/etc/sysctl/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ # 4194304 is the maximum limit possible on 64-bit CONFIG_BASE_FULL kernels.
+ # Keep the default for 32-bit systems.
+ set(sysctl_pid_max "kernel.pid_max = 4194304")
+endif()
+
+configure_file(90-ceph-osd.conf.in
+ ${CMAKE_CURRENT_SOURCE_DIR}/90-ceph-osd.conf
+ @ONLY)