summaryrefslogtreecommitdiffstats
path: root/qa/workunits/direct_io/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'qa/workunits/direct_io/Makefile')
-rw-r--r--qa/workunits/direct_io/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/qa/workunits/direct_io/Makefile b/qa/workunits/direct_io/Makefile
new file mode 100644
index 000000000..20fec0be5
--- /dev/null
+++ b/qa/workunits/direct_io/Makefile
@@ -0,0 +1,11 @@
+CFLAGS = -Wall -Wextra -D_GNU_SOURCE
+
+TARGETS = direct_io_test test_sync_io test_short_dio_read
+
+.c:
+ $(CC) $(CFLAGS) $@.c -o $@
+
+all: $(TARGETS)
+
+clean:
+ rm $(TARGETS)