summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/assert/test/cmake_subdir_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/assert/test/cmake_subdir_test/CMakeLists.txt')
-rw-r--r--src/boost/libs/assert/test/cmake_subdir_test/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/boost/libs/assert/test/cmake_subdir_test/CMakeLists.txt b/src/boost/libs/assert/test/cmake_subdir_test/CMakeLists.txt
new file mode 100644
index 000000000..80efc8571
--- /dev/null
+++ b/src/boost/libs/assert/test/cmake_subdir_test/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright 2018 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(cmake_subdir_test LANGUAGES CXX)
+
+add_subdirectory(../../../assert boostorg/assert)
+add_subdirectory(../../../config boostorg/config)
+
+add_executable(main main.cpp)
+target_link_libraries(main Boost::assert)
+
+enable_testing()
+add_test(NAME main COMMAND main)
+
+add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure -C $<CONFIG>)