summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/beast/example/http/client/async-ssl-system-executor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/beast/example/http/client/async-ssl-system-executor/CMakeLists.txt')
-rw-r--r--src/boost/libs/beast/example/http/client/async-ssl-system-executor/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/boost/libs/beast/example/http/client/async-ssl-system-executor/CMakeLists.txt b/src/boost/libs/beast/example/http/client/async-ssl-system-executor/CMakeLists.txt
new file mode 100644
index 000000000..049a2fea9
--- /dev/null
+++ b/src/boost/libs/beast/example/http/client/async-ssl-system-executor/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+if (OPENSSL_FOUND)
+ GroupSources(include/boost/beast beast)
+ GroupSources(example/common common)
+ GroupSources(example/http/client/async-ssl-system-executor "/")
+
+ add_executable (http-client-async-ssl-system-executor
+ ${BOOST_BEAST_FILES}
+ ${PROJECT_SOURCE_DIR}/example/common/root_certificates.hpp
+ Jamfile
+ http_client_async_ssl_system_executor.cpp
+ )
+
+ set_property(TARGET http-client-async-ssl-system-executor PROPERTY FOLDER "example-http-client")
+
+ target_link_libraries (http-client-async-ssl-system-executor
+ OpenSSL::SSL OpenSSL::Crypto
+ lib-asio
+ lib-asio-ssl
+ lib-beast
+ )
+
+endif()