summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/beast/example/http/server/coro/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/beast/example/http/server/coro/CMakeLists.txt')
-rw-r--r--src/boost/libs/beast/example/http/server/coro/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/boost/libs/beast/example/http/server/coro/CMakeLists.txt b/src/boost/libs/beast/example/http/server/coro/CMakeLists.txt
new file mode 100644
index 000000000..6cc8244a8
--- /dev/null
+++ b/src/boost/libs/beast/example/http/server/coro/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+GroupSources(include/boost/beast beast)
+GroupSources(example/http/server/coro "/")
+
+add_executable (http-server-coro
+ ${BOOST_BEAST_FILES}
+ Jamfile
+ http_server_coro.cpp
+)
+
+target_link_libraries(http-server-coro
+ lib-asio
+ lib-beast)
+
+set_property(TARGET http-server-coro PROPERTY FOLDER "example-http-server")