summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/beast/example/websocket/server/stackless/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/beast/example/websocket/server/stackless/CMakeLists.txt')
-rw-r--r--src/boost/libs/beast/example/websocket/server/stackless/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/boost/libs/beast/example/websocket/server/stackless/CMakeLists.txt b/src/boost/libs/beast/example/websocket/server/stackless/CMakeLists.txt
new file mode 100644
index 000000000..b260ca48b
--- /dev/null
+++ b/src/boost/libs/beast/example/websocket/server/stackless/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+GroupSources(include/boost/beast beast)
+GroupSources(example/websocket/server/stackless "/")
+
+add_executable (websocket-server-stackless
+ ${BOOST_BEAST_FILES}
+ Jamfile
+ websocket_server_stackless.cpp
+)
+
+target_link_libraries(websocket-server-stackless
+ lib-asio
+ lib-beast)
+
+set_property(TARGET websocket-server-stackless PROPERTY FOLDER "example-websocket-server")