summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/detail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/detail/CMakeLists.txt')
-rw-r--r--src/boost/libs/detail/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/boost/libs/detail/CMakeLists.txt b/src/boost/libs/detail/CMakeLists.txt
new file mode 100644
index 000000000..3e122d429
--- /dev/null
+++ b/src/boost/libs/detail/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright 2018 Peter Dimov
+# Copyright 2018 Andrey Semashev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+
+# Partial (add_subdirectory only) and experimental CMake support
+# Subject to change; please do not rely on the contents of this file yet.
+
+cmake_minimum_required(VERSION 3.5)
+
+project(BoostDetail LANGUAGES CXX)
+
+add_library(boost_detail INTERFACE)
+add_library(Boost::detail ALIAS boost_detail)
+
+target_include_directories(boost_detail INTERFACE include)
+
+target_link_libraries(boost_detail
+ INTERFACE
+ Boost::config
+ Boost::core
+ Boost::preprocessor
+ Boost::static_assert
+ Boost::type_traits
+)