summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/mp11/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/mp11/test/CMakeLists.txt')
-rw-r--r--src/boost/libs/mp11/test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/boost/libs/mp11/test/CMakeLists.txt b/src/boost/libs/mp11/test/CMakeLists.txt
new file mode 100644
index 000000000..cab19b651
--- /dev/null
+++ b/src/boost/libs/mp11/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Copyright 2018 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+include(BoostTestJamfile OPTIONAL RESULT_VARIABLE HAVE_BOOST_TEST)
+
+if(HAVE_BOOST_TEST)
+
+boost_test_jamfile(FILE Jamfile LINK_LIBRARIES Boost::mp11 Boost::core)
+boost_test(SOURCES check_cmake_version.cpp ARGUMENTS ${PROJECT_VERSION} LINK_LIBRARIES Boost::core Boost::config)
+
+endif()