summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/signals2/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/signals2/example/CMakeLists.txt')
-rw-r--r--src/boost/libs/signals2/example/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/boost/libs/signals2/example/CMakeLists.txt b/src/boost/libs/signals2/example/CMakeLists.txt
new file mode 100644
index 000000000..3b42e58d8
--- /dev/null
+++ b/src/boost/libs/signals2/example/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright 2019 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: CMake support for Boost.Signals2 is currently experimental at best
+# and the interface is likely to change in the future
+
+file( GLOB example_src_files *.cpp )
+
+find_package(Threads REQUIRED)
+
+foreach( file IN LISTS example_src_files )
+
+ get_filename_component( example_name ${file} NAME_WE )
+
+ add_executable( boost_signals2_example_${example_name} ${file} )
+ target_link_libraries( boost_signals2_example_${example_name}
+ PUBLIC
+ Boost::signals2
+ Boost::io
+ Threads::Threads
+ )
+
+endforeach()