summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/variant2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/variant2/CMakeLists.txt')
-rw-r--r--src/boost/libs/variant2/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/boost/libs/variant2/CMakeLists.txt b/src/boost/libs/variant2/CMakeLists.txt
new file mode 100644
index 000000000..9d509eee0
--- /dev/null
+++ b/src/boost/libs/variant2/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright 2018, 2019 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# http://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(boost_variant2 VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_variant2 INTERFACE)
+add_library(Boost::variant2 ALIAS boost_variant2)
+
+target_include_directories(boost_variant2 INTERFACE include)
+
+target_link_libraries(boost_variant2
+ INTERFACE
+ Boost::config
+ Boost::mp11
+)
+
+if(BOOST_SUPERPROJECT_VERSION)
+
+ include(BoostInstall)
+ boost_install(TARGETS boost_variant2 HEADER_DIRECTORY include/)
+
+endif()
+
+if(BUILD_TESTING)
+
+ add_subdirectory(test)
+
+endif()