summaryrefslogtreecommitdiffstats
path: root/src/erasure-code/clay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/erasure-code/clay/CMakeLists.txt')
-rw-r--r--src/erasure-code/clay/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/erasure-code/clay/CMakeLists.txt b/src/erasure-code/clay/CMakeLists.txt
new file mode 100644
index 000000000..c5af1e226
--- /dev/null
+++ b/src/erasure-code/clay/CMakeLists.txt
@@ -0,0 +1,14 @@
+# clay plugin
+
+set(clay_srcs
+ ErasureCodePluginClay.cc
+ ErasureCodeClay.cc
+ $<TARGET_OBJECTS:erasure_code_objs>
+ $<TARGET_OBJECTS:crush_objs>
+ ${CMAKE_SOURCE_DIR}/src/common/str_map.cc
+)
+
+add_library(ec_clay SHARED ${clay_srcs})
+set_target_properties(ec_clay PROPERTIES
+ INSTALL_RPATH "")
+install(TARGETS ec_clay DESTINATION ${erasure_plugin_dir})