summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/test/perl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/jaegertracing/thrift/test/perl/Makefile.am')
-rw-r--r--src/jaegertracing/thrift/test/perl/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/test/perl/Makefile.am b/src/jaegertracing/thrift/test/perl/Makefile.am
new file mode 100644
index 000000000..1dbaf28b0
--- /dev/null
+++ b/src/jaegertracing/thrift/test/perl/Makefile.am
@@ -0,0 +1,31 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+stubs: ../ThriftTest.thrift
+ $(THRIFT) --gen perl ../ThriftTest.thrift
+
+precross: stubs
+
+check: stubs
+
+clean-local:
+ $(RM) -r gen-perl/
+
+dist-hook:
+ $(RM) -r $(distdir)/gen-perl/