summaryrefslogtreecommitdiffstats
path: root/src/ocf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ocf/CMakeLists.txt')
-rw-r--r--src/ocf/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/ocf/CMakeLists.txt b/src/ocf/CMakeLists.txt
new file mode 100644
index 000000000..9a87d02f1
--- /dev/null
+++ b/src/ocf/CMakeLists.txt
@@ -0,0 +1,10 @@
+# The root of the OCF resource agent hierarchy
+# Per the OCF standard, it's always "lib",
+# not "lib64" (even on 64-bit platforms).
+set(ocf_dir ${CMAKE_INSTALL_PREFIX}/lib/ocf)
+
+# The ceph provider directory
+set(ra_dir ${ocf_dir}/resource.d/${PROJECT_NAME})
+
+configure_file(rbd.in rbd @ONLY)
+install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/rbd DESTINATION ${ra_dir})