summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/rook/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/mgr/rook/CMakeLists.txt')
-rw-r--r--src/pybind/mgr/rook/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/pybind/mgr/rook/CMakeLists.txt b/src/pybind/mgr/rook/CMakeLists.txt
new file mode 100644
index 000000000..206e165e6
--- /dev/null
+++ b/src/pybind/mgr/rook/CMakeLists.txt
@@ -0,0 +1,15 @@
+include(ExternalProject)
+
+ExternalProject_Add(mgr-rook-client
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/rook-client-python/rook_client"
+ # use INSTALL_DIR for destination dir
+ INSTALL_DIR "${CMAKE_CURRENT_SOURCE_DIR}/rook_client"
+ CONFIGURE_COMMAND ""
+ BUILD_COMMAND ${CMAKE_COMMAND} -E make_directory <INSTALL_DIR>
+ COMMAND ${CMAKE_COMMAND} -E copy_directory <SOURCE_DIR>/ceph <INSTALL_DIR>/ceph
+ COMMAND ${CMAKE_COMMAND} -E copy <SOURCE_DIR>/__init__.py <INSTALL_DIR>
+ COMMAND ${CMAKE_COMMAND} -E copy <SOURCE_DIR>/_helper.py <INSTALL_DIR>
+ BUILD_BYPRODUCTS "<INSTALL_DIR>/__init__.py"
+ INSTALL_COMMAND "")
+
+add_dependencies(ceph-mgr mgr-rook-client)