summaryrefslogtreecommitdiffstats
path: root/src/pybind/rgw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/rgw/CMakeLists.txt')
-rw-r--r--src/pybind/rgw/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/pybind/rgw/CMakeLists.txt b/src/pybind/rgw/CMakeLists.txt
new file mode 100644
index 000000000..2c8309cdd
--- /dev/null
+++ b/src/pybind/rgw/CMakeLists.txt
@@ -0,0 +1,7 @@
+distutils_add_cython_module(cython${PYTHON_VERSION}_rgw
+ rgw
+ ${CMAKE_CURRENT_SOURCE_DIR}/rgw.pyx
+ ${PYTHON_VERSION})
+add_dependencies(cython${PYTHON_VERSION}_rgw rgw)
+distutils_install_cython_module(cython${PYTHON_VERSION}_rgw
+ ${PYTHON_VERSION})