summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/crypto/octeontx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/drivers/crypto/octeontx/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/crypto/octeontx/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/crypto/octeontx/meson.build b/src/seastar/dpdk/drivers/crypto/octeontx/meson.build
new file mode 100644
index 000000000..a9f2d3157
--- /dev/null
+++ b/src/seastar/dpdk/drivers/crypto/octeontx/meson.build
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Cavium, Inc
+if not is_linux
+ build = false
+endif
+
+deps += ['bus_pci']
+deps += ['common_cpt']
+name = 'octeontx_crypto'
+
+allow_experimental_apis = true
+sources = files('otx_cryptodev.c',
+ 'otx_cryptodev_capabilities.c',
+ 'otx_cryptodev_hw_access.c',
+ 'otx_cryptodev_mbox.c',
+ 'otx_cryptodev_ops.c')
+
+includes += include_directories('../../common/cpt')