summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/event/octeontx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/drivers/event/octeontx/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/event/octeontx/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/event/octeontx/meson.build b/src/seastar/dpdk/drivers/event/octeontx/meson.build
new file mode 100644
index 000000000..2b74bb62d
--- /dev/null
+++ b/src/seastar/dpdk/drivers/event/octeontx/meson.build
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Cavium, Inc
+
+sources = files('ssovf_worker.c',
+ 'ssovf_evdev.c',
+ 'ssovf_evdev_selftest.c',
+ 'ssovf_probe.c',
+ 'timvf_worker.c',
+ 'timvf_evdev.c',
+ 'timvf_probe.c'
+)
+
+deps += ['common_octeontx', 'mempool_octeontx', 'bus_vdev', 'pmd_octeontx']