summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/net/ixgbe/base/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/drivers/net/ixgbe/base/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/net/ixgbe/base/meson.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/net/ixgbe/base/meson.build b/src/seastar/dpdk/drivers/net/ixgbe/base/meson.build
new file mode 100644
index 000000000..21ac64bf5
--- /dev/null
+++ b/src/seastar/dpdk/drivers/net/ixgbe/base/meson.build
@@ -0,0 +1,35 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+sources = [
+ 'ixgbe_82598.c',
+ 'ixgbe_82599.c',
+ 'ixgbe_api.c',
+ 'ixgbe_common.c',
+ 'ixgbe_dcb_82598.c',
+ 'ixgbe_dcb_82599.c',
+ 'ixgbe_dcb.c',
+ 'ixgbe_hv_vf.c',
+ 'ixgbe_mbx.c',
+ 'ixgbe_phy.c',
+ 'ixgbe_vf.c',
+ 'ixgbe_x540.c',
+ 'ixgbe_x550.c'
+]
+
+error_cflags = ['-Wno-unused-value',
+ '-Wno-unused-but-set-variable']
+c_args = cflags
+if allow_experimental_apis
+ c_args += '-DALLOW_EXPERIMENTAL_API'
+endif
+foreach flag: error_cflags
+ if cc.has_argument(flag)
+ c_args += flag
+ endif
+endforeach
+
+base_lib = static_library('ixgbe_base', sources,
+ dependencies: static_rte_eal,
+ c_args: c_args)
+base_objs = base_lib.extract_all_objects()